$re = '/www\.[0-9]*\.xyz$/m';
$str = 'xyz.domain.com
www.domainwithxyz.com
www.xyz.com
www.somedomain.xyz
www.0123456.xyz
www.156489.xyz
www.321a5487.xyz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);