re = /www\.[0-9]*\.xyz$/m
str = 'xyz.domain.com
www.domainwithxyz.com
www.xyz.com
www.somedomain.xyz
www.0123456.xyz
www.156489.xyz
www.321a5487.xyz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end