use strict;
my $str = 'xyz.domain.com
www.domainwithxyz.com
www.xyz.com
www.somedomain.xyz
www.0123456.xyz
www.156489.xyz
www.321a5487.xyz';
my $regex = qr/www\.[0-9]*\.xyz$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}