// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)www\.[0-9]*\.xyz$").unwrap();
let string = "xyz.domain.com
www.domainwithxyz.com
www.xyz.com
www.somedomain.xyz
www.0123456.xyz
www.156489.xyz
www.321a5487.xyz";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}