#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*\bMAIN LEVEL\b\n(?:(?!\n\n)[\s\S])*\bBedrooms:\s*(.*)"
Local $sString = "" & @CRLF & _
" MAIN LEVEL" & @CRLF & _
" Entrance: 11" & @CRLF & _
" Living: 22" & @CRLF & _
" Dining: 333" & @CRLF & _
" Kitchen: 444" & @CRLF & _
" Family: 555" & @CRLF & _
" Bedrooms: 666" & @CRLF & _
" Den: 777" & @CRLF & _
"" & @CRLF & _
" SECOND LEVEL" & @CRLF & _
" Entrance: 1111" & @CRLF & _
" Living: 2222" & @CRLF & _
" Dining: 3333" & @CRLF & _
" Kitchen: 4444" & @CRLF & _
" Family: 5555" & @CRLF & _
" Bedrooms: 6666" & @CRLF & _
"" & @CRLF & _
" THIRD LEVEL" & @CRLF & _
" Entrance: 3333" & @CRLF & _
" Living: 334" & @CRLF & _
" Dining: 3332" & @CRLF & _
" Kitchen: 33336" & @CRLF & _
" Family: 33332" & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")