use strict;
my $str = '
MAIN LEVEL
Entrance: 11
Living: 22
Dining: 333
Kitchen: 444
Family: 555
Bedrooms: 666
Den: 777
SECOND LEVEL
Entrance: 1111
Living: 2222
Dining: 3333
Kitchen: 4444
Family: 5555
Bedrooms: 6666
THIRD LEVEL
Entrance: 3333
Living: 334
Dining: 3332
Kitchen: 33336
Family: 33332
';
my $regex = qr/^\s*\bMAIN LEVEL\b\n(?:(?!\n\n)[\s\S])*\bBedrooms:\s*(.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}