# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*\bMAIN LEVEL\b\n(?:(?!\n\n)[\s\S])*\bBedrooms:\s*(.*)"
test_str = ("\n"
" MAIN LEVEL\n"
" Entrance: 11\n"
" Living: 22\n"
" Dining: 333\n"
" Kitchen: 444\n"
" Family: 555\n"
" Bedrooms: 666\n"
" Den: 777\n\n"
" SECOND LEVEL\n"
" Entrance: 1111\n"
" Living: 2222\n"
" Dining: 3333\n"
" Kitchen: 4444\n"
" Family: 5555\n"
" Bedrooms: 6666\n\n"
" THIRD LEVEL\n"
" Entrance: 3333\n"
" Living: 334\n"
" Dining: 3332\n"
" Kitchen: 33336\n"
" Family: 33332\n"
" ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.