import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*\\bMAIN LEVEL\\b\\n(?:(?!\\n\\n)[\\s\\S])*\\bBedrooms:\\s*(.*)";
final String string = "\n"
+ " MAIN LEVEL\n"
+ " Entrance: 11\n"
+ " Living: 22\n"
+ " Dining: 333\n"
+ " Kitchen: 444\n"
+ " Family: 555\n"
+ " Bedrooms: 666\n"
+ " Den: 777\n\n"
+ " SECOND LEVEL\n"
+ " Entrance: 1111\n"
+ " Living: 2222\n"
+ " Dining: 3333\n"
+ " Kitchen: 4444\n"
+ " Family: 5555\n"
+ " Bedrooms: 6666\n\n"
+ " THIRD LEVEL\n"
+ " Entrance: 3333\n"
+ " Living: 334\n"
+ " Dining: 3332\n"
+ " Kitchen: 33336\n"
+ " Family: 33332\n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}