using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"O [^A-Z]*(?<myfield>[A-Z\-\s]+) \[";
string input = @"[7/03/16 11:32:49:079 EST] 000000b4 SystemOut O TST [WebContainer : 4]
[7/03/16 11:32:49:101 EST] 00000060 SystemOut O nevo-web CI-TST [WebContainer : 0]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}