$re = '/O [^A-Z]*(?<myfield>[A-Z\-\s]+) \[/';
$str = '[7/03/16 11:32:49:079 EST] 000000b4 SystemOut O TST [WebContainer : 4]
[7/03/16 11:32:49:101 EST] 00000060 SystemOut O nevo-web CI-TST [WebContainer : 0]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);