import re
regex = re.compile(r"O [^A-Z]*(?<myfield>[A-Z\-\s]+) \[")
test_str = ("[7/03/16 11:32:49:079 EST] 000000b4 SystemOut O TST [WebContainer : 4]\n"
"[7/03/16 11:32:49:101 EST] 00000060 SystemOut O nevo-web CI-TST [WebContainer : 0]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")