import Foundation
let pattern = #"O [^A-Z]*(?<myfield>[A-Z\-\s]+) \["#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[7/03/16 11:32:49:079 EST] 000000b4 SystemOut O TST [WebContainer : 4]
[7/03/16 11:32:49:101 EST] 00000060 SystemOut O nevo-web CI-TST [WebContainer : 0]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)