re = /O [^A-Z]*(?<myfield>[A-Z\-\s]+) \[/
str = '[7/03/16 11:32:49:079 EST] 000000b4 SystemOut O TST [WebContainer : 4]
[7/03/16 11:32:49:101 EST] 00000060 SystemOut O nevo-web CI-TST [WebContainer : 0]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end