#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "@([^\s:]+)"
Local $sString = "@galaxy5univ I like you" & @CRLF & _
"RT @BestOfGalaxies: Let's sit under the stars ..." & @CRLF & _
"@jonghyun__bot .........((thanks)" & @CRLF & _
"RT @yosizo: thanks.ddddd <https://yahoo.com>" & @CRLF & _
"RT @LDH_3_yui: #fam, ccccc https://msn.news.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")