package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`@([^\s:]+)`)
var str = `@galaxy5univ I like you
RT @BestOfGalaxies: Let's sit under the stars ...
@jonghyun__bot .........((thanks)
RT @yosizo: thanks.ddddd <https://yahoo.com>
RT @LDH_3_yui: #fam, ccccc https://msn.news.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}