const regex = new RegExp('@([^\\s:]+)', 'g')
const str = `@galaxy5univ I like you
RT @BestOfGalaxies: Let's sit under the stars ...
@jonghyun__bot .........((thanks)
RT @yosizo: thanks.ddddd <https://yahoo.com>
RT @LDH_3_yui: #fam, ccccc https://msn.news.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}