re = /@([^\s:]+)/
str = '@galaxy5univ I like you
RT @BestOfGalaxies: Let\'s sit under the stars ...
@jonghyun__bot .........((thanks)
RT @yosizo: thanks.ddddd <https://yahoo.com>
RT @LDH_3_yui: #fam, ccccc https://msn.news.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end