using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[A-Z]{1})([a-z]+)(\s[A-Z]{1}([a-z]+))(\s[A-Z]{1}([a-z]+))?\s?\.*$";
string input = @"Nguyen Quang Do .";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}