package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^[A-Z]{1})([a-z]+)(\s[A-Z]{1}([a-z]+))(\s[A-Z]{1}([a-z]+))?\s?\.*$`)
var str = `Nguyen Quang Do .`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}