$re = '/(^[A-Z]{1})([a-z]+)(\s[A-Z]{1}([a-z]+))(\s[A-Z]{1}([a-z]+))?\s?\.*$/';
$str = 'Nguyen Quang Do .';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);