const regex = /(^[A-Z]{1})([a-z]+)(\s[A-Z]{1}([a-z]+))(\s[A-Z]{1}([a-z]+))?\s?\.*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[A-Z]{1})([a-z]+)(\\s[A-Z]{1}([a-z]+))(\\s[A-Z]{1}([a-z]+))?\\s?\\.*$', '')
const str = `Nguyen Quang Do .`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}