re = /(^[A-Z]{1})([a-z]+)(\s[A-Z]{1}([a-z]+))(\s[A-Z]{1}([a-z]+))?\s?\.*$/
str = 'Nguyen Quang Do .'
# Print the match result
str.match(re) do |match|
puts match.to_s
end