#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=^.{8,}$)(?!^\d)(?!.*\d$)(?!.+\d\d)(?=.*[&%$^#@=])(?=(.*[A-Z]){2})(?=(.*[a-z]){2})(?=(.*[0-9]){2})"
Local $sString = "aa1$1BB" & @CRLF & _
"bbAZ9$Zfx" & @CRLF & _
"bbAZ9$Zf" & @CRLF & _
"b8A9$Zfy" & @CRLF & _
"b7AZ9$fy" & @CRLF & _
"b8A$Zfy4" & @CRLF & _
"6bA$Z8yt" & @CRLF & _
"7bA$Z8y4" & @CRLF & _
"b8A$Z47y" & @CRLF & _
"b8A$ZSyg" & @CRLF & _
"b8A$Z8yg" & @CRLF & _
"b8A$xf4y" & @CRLF & _
"A8bb=4cd" & @CRLF & _
"12345678AA1bb2=a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")