re = /(?=^.{8,}$)(?!^\d)(?!.*\d$)(?!.+\d\d)(?=.*[&%$^#@=])(?=(.*[A-Z]){2})(?=(.*[a-z]){2})(?=(.*[0-9]){2})/m
str = 'aa1$1BB
bbAZ9$Zfx
bbAZ9$Zf
b8A9$Zfy
b7AZ9$fy
b8A$Zfy4
6bA$Z8yt
7bA$Z8y4
b8A$Z47y
b8A$ZSyg
b8A$Z8yg
b8A$xf4y
A8bb=4cd
12345678AA1bb2=a'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end