using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=^.{8,}$)(?!^\d)(?!.*\d$)(?!.+\d\d)(?=.*[&%$^#@=])(?=(.*[A-Z]){2})(?=(.*[a-z]){2})(?=(.*[0-9]){2})";
string input = @"aa1$1BB
bbAZ9$Zfx
bbAZ9$Zf
b8A9$Zfy
b7AZ9$fy
b8A$Zfy4
6bA$Z8yt
7bA$Z8y4
b8A$Z47y
b8A$ZSyg
b8A$Z8yg
b8A$xf4y
A8bb=4cd
12345678AA1bb2=a";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}