const regex = /(?=^.{8,}$)(?!^\d)(?!.*\d$)(?!.+\d\d)(?=.*[&%$^#@=])(?=(.*[A-Z]){2})(?=(.*[a-z]){2})(?=(.*[0-9]){2})/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=^.{8,}$)(?!^\\d)(?!.*\\d$)(?!.+\\d\\d)(?=.*[&%$^#@=])(?=(.*[A-Z]){2})(?=(.*[a-z]){2})(?=(.*[0-9]){2})', 'mg')
const str = `aa1\$1BB
bbAZ9\$Zfx
bbAZ9\$Zf
b8A9\$Zfy
b7AZ9\$fy
b8A\$Zfy4
6bA\$Z8yt
7bA\$Z8y4
b8A\$Z47y
b8A\$ZSyg
b8A\$Z8yg
b8A\$xf4y
A8bb=4cd
12345678AA1bb2=a`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}