import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=^.{8,}$)(?!^\\d)(?!.*\\d$)(?!.+\\d\\d)(?=.*[&%$^#@=])(?=(.*[A-Z]){2})(?=(.*[a-z]){2})(?=(.*[0-9]){2})";
final String string = "aa1$1BB\n"
+ "bbAZ9$Zfx\n"
+ "bbAZ9$Zf\n"
+ "b8A9$Zfy\n"
+ "b7AZ9$fy\n"
+ "b8A$Zfy4\n"
+ "6bA$Z8yt\n"
+ "7bA$Z8y4\n"
+ "b8A$Z47y\n"
+ "b8A$ZSyg\n"
+ "b8A$Z8yg\n"
+ "b8A$xf4y\n"
+ "A8bb=4cd\n"
+ "12345678AA1bb2=a";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}