#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?: # group, but do not capture:" & @CRLF & _
" foo # 'foo'" & @CRLF & _
" | # OR" & @CRLF & _
" bar # 'bar'" & @CRLF & _
" | # OR" & @CRLF & _
" baz # 'baz'" & @CRLF & _
") # end of grouping" & @CRLF & _
"(?= # look ahead to see if there is:" & @CRLF & _
" quz # 'quz'" & @CRLF & _
") # end of look-ahead"
Local $sString = "fooquz"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")