use strict;
my $str = 'fooquz';
my $regex = qr/(?: # group, but do not capture:
foo # 'foo'
| # OR
bar # 'bar'
| # OR
baz # 'baz'
) # end of grouping
(?= # look ahead to see if there is:
quz # 'quz'
) # end of look-ahead/xp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}