re = /(?: # group, but do not capture:
foo # 'foo'
| # OR
bar # 'bar'
| # OR
baz # 'baz'
) # end of grouping
(?= # look ahead to see if there is:
quz # 'quz'
) # end of look-ahead/x
str = 'fooquz'
# Print the match result
str.match(re) do |match|
puts match.to_s
end