const regex = /(?: # group, but do not capture:
foo # 'foo'
| # OR
bar # 'bar'
| # OR
baz # 'baz'
) # end of grouping
(?= # look ahead to see if there is:
quz # 'quz'
) # end of look-ahead/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?: # group, but do not capture:
foo # \'foo\'
| # OR
bar # \'bar\'
| # OR
baz # \'baz\'
) # end of grouping
(?= # look ahead to see if there is:
quz # \'quz\'
) # end of look-ahead', '')
const str = `fooquz`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}