#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<button[^<]*>.*[\s\S]*<\/button>|<iframe[^<>]*\/>|<tr>[^<td>]*<\/tr>"
Local $sString = "<table width="30px">" & @CRLF & _
"<P>Teste</p><iframe src="teste" /><p>Test</p>" & @CRLF & _
"<div><span>Teste Regex</span></div>" & @CRLF & _
"<p>Test</p><button onclick="myFunction()">Click me</button>" & @CRLF & _
"<table>" & @CRLF & _
"<tr><td>34</td></tr>>" & @CRLF & _
"</table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")