import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<button[^<]*>.*[\\s\\S]*<\\/button>|<iframe[^<>]*\\/>|<tr>[^<td>]*<\\/tr>";
final String string = "<table width=\"30px\">\n"
+ "<P>Teste</p><iframe src=\"teste\" /><p>Test</p>\n"
+ "<div><span>Teste Regex</span></div>\n"
+ "<p>Test</p><button onclick=\"myFunction()\">Click me</button>\n"
+ "<table>\n"
+ "<tr><td>34</td></tr>>\n"
+ "</table>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}