const regex = /<button[^<]*>.*[\s\S]*<\/button>|<iframe[^<>]*\/>|<tr>[^<td>]*<\/tr>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<button[^<]*>.*[\\s\\S]*<\\\/button>|<iframe[^<>]*\\\/>|<tr>[^<td>]*<\\\/tr>', 'g')
const str = `<table width="30px">
<P>Teste</p><iframe src="teste" /><p>Test</p>
<div><span>Teste Regex</span></div>
<p>Test</p><button onclick="myFunction()">Click me</button>
<table>
<tr><td>34</td></tr>>
</table>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}