using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<button[^<]*>.*[\s\S]*<\/button>|<iframe[^<>]*\/>|<tr>[^<td>]*<\/tr>";
string input = @"<table width=""30px"">
<P>Teste</p><iframe src=""teste"" /><p>Test</p>
<div><span>Teste Regex</span></div>
<p>Test</p><button onclick=""myFunction()"">Click me</button>
<table>
<tr><td>34</td></tr>>
</table>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}