// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<button[^<]*>.*[\s\S]*<\/button>|<iframe[^<>]*\/>|<tr>[^<td>]*<\/tr>").unwrap();
let string = "<table width=\"30px\">
<P>Teste</p><iframe src=\"teste\" /><p>Test</p>
<div><span>Teste Regex</span></div>
<p>Test</p><button onclick=\"myFunction()\">Click me</button>
<table>
<tr><td>34</td></tr>>
</table>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}