using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+(?:\.\d+)?[<>-]+(\d+(?:\.\d+)?).*";
string input = @"7.20-<7.35
25-<32
60-<83e
40-<50
0.85-<1.15
80-<98
3.0-<3.4
NA
3.0-<3.4 (110)
0.85-1.15
0.85>1.15
0.85->1.15";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}