import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+(?:\\.\\d+)?[<>-]+(\\d+(?:\\.\\d+)?).*";
final String string = "7.20-<7.35\n"
+ "25-<32\n"
+ "60-<83e\n"
+ "40-<50\n"
+ "0.85-<1.15\n"
+ "80-<98\n"
+ "3.0-<3.4\n"
+ "NA\n"
+ "3.0-<3.4 (110)\n"
+ "0.85-1.15\n"
+ "0.85>1.15\n"
+ "0.85->1.15";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}