re = /\d+(?:\.\d+)?[<>-]+(\d+(?:\.\d+)?).*/m
str = '7.20-<7.35
25-<32
60-<83e
40-<50
0.85-<1.15
80-<98
3.0-<3.4
NA
3.0-<3.4 (110)
0.85-1.15
0.85>1.15
0.85->1.15'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end