import re
regex = re.compile(r"\d+(?:\.\d+)?[<>-]+(\d+(?:\.\d+)?).*", flags=re.MULTILINE)
test_str = ("7.20-<7.35\n"
"25-<32\n"
"60-<83e\n"
"40-<50\n"
"0.85-<1.15\n"
"80-<98\n"
"3.0-<3.4\n"
"NA\n"
"3.0-<3.4 (110)\n"
"0.85-1.15\n"
"0.85>1.15\n"
"0.85->1.15")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")