#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "https?:\/\/[a-z0-9-]+(.[a-z0-9-]+)*(:[0-9]+)?(\/.*)?(?=.url.com)(.url.com)"
Local $sString = "https://ok1.url.com" & @CRLF & _
"http://ok2.url.com" & @CRLF & _
"https://not.ok.temp.com" & @CRLF & _
"http://not-ok.either.w3.com" & @CRLF & _
"http://no1.w3.org" & @CRLF & _
"http://temp.bla.com" & @CRLF & _
"http://no4.temp.bla" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")