re = /https?:\/\/[a-z0-9-]+(.[a-z0-9-]+)*(:[0-9]+)?(\/.*)?(?=.url.com)(.url.com)/
str = 'https://ok1.url.com
http://ok2.url.com
https://not.ok.temp.com
http://not-ok.either.w3.com
http://no1.w3.org
http://temp.bla.com
http://no4.temp.bla
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end