import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/[a-z0-9-]+(.[a-z0-9-]+)*(:[0-9]+)?(\\/.*)?(?=.url.com)(.url.com)";
final String string = "https://ok1.url.com\n"
+ "http://ok2.url.com\n"
+ "https://not.ok.temp.com\n"
+ "http://not-ok.either.w3.com\n"
+ "http://no1.w3.org\n"
+ "http://temp.bla.com\n"
+ "http://no4.temp.bla\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}