const regex = /https?:\/\/[a-z0-9-]+(.[a-z0-9-]+)*(:[0-9]+)?(\/.*)?(?=.url.com)(.url.com)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/[a-z0-9-]+(.[a-z0-9-]+)*(:[0-9]+)?(\\\/.*)?(?=.url.com)(.url.com)', 'g')
const str = `https://ok1.url.com
http://ok2.url.com
https://not.ok.temp.com
http://not-ok.either.w3.com
http://no1.w3.org
http://temp.bla.com
http://no4.temp.bla
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}