using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/[a-z0-9-]+(.[a-z0-9-]+)*(:[0-9]+)?(\/.*)?(?=.url.com)(.url.com)";
string input = @"https://ok1.url.com
http://ok2.url.com
https://not.ok.temp.com
http://not-ok.either.w3.com
http://no1.w3.org
http://temp.bla.com
http://no4.temp.bla
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}