import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?://(?:www\\.|)([\\w.-]+).*";
final String string = "https://domen.site.ru/podsait/03285926/#2412747495\n"
+ "http://www.site.ru/site/24722305\n"
+ "https://www.domen.site.ru/site/247493215/site\n"
+ "site.ru";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}