# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"https?://(?:www\.|)([\w.-]+).*"
test_str = ("https://domen.site.ru/podsait/03285926/#2412747495\n"
"http://www.site.ru/site/24722305\n"
"https://www.domen.site.ru/site/247493215/site\n"
"site.ru")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.