import Foundation
let pattern = #"https?://(?:www\.|)([\w.-]+).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
https://domen.site.ru/podsait/03285926/#2412747495
http://www.site.ru/site/24722305
https://www.domen.site.ru/site/247493215/site
site.ru
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)