# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[0-9]+(?=_)/666/;t' <<< "string/1_491107.jpg"