use strict;
my $str = 'string/1_491107.jpg';
my $regex = qr/[0-9]+(?=_)/p;
my $subst = '666';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";